xin/pkgs/sliding-sync.nix

26 lines
662 B
Nix

{ lib, buildGoModule, fetchFromGitHub, ... }:
with lib;
buildGoModule rec {
pname = "sliding-sync";
version = "0.99.2";
src = fetchFromGitHub {
owner = "matrix-org";
repo = pname;
rev = "v${version}";
hash = "sha256-QbTCr1dsJX8nlLE3PhevBbLv1dnvLTMkOiKgTeThlKw=";
};
vendorHash = "sha256-EIFUuWwpNUtWy6lSNeIEwe3gjyb3yq/WRJEND9YhQjs=";
# Note: tests require a postgres install accessible to the current user
doCheck = false;
meta = {
description = "An implementation of MSC3575";
homepage = "https://github.com/matrix-org/sliding-sync";
license = licenses.asl20;
maintainers = with maintainers; [ qbit ];
};
}