43 lines
1.3 KiB
Nix
43 lines
1.3 KiB
Nix
{
|
|
config,
|
|
lib,
|
|
modulesPath,
|
|
...
|
|
}: {
|
|
imports = [(modulesPath + "/installer/scan/not-detected.nix")];
|
|
|
|
boot.initrd.availableKernelModules = [
|
|
"uhci_hcd"
|
|
"ehci_pci"
|
|
"ata_piix"
|
|
"megaraid_sas"
|
|
"usb_storage"
|
|
"usbhid"
|
|
"sd_mod"
|
|
"sr_mod"
|
|
];
|
|
boot.initrd.kernelModules = [];
|
|
boot.kernelModules = ["kvm-intel"];
|
|
boot.extraModulePackages = [];
|
|
|
|
fileSystems."/" = {
|
|
device = "/dev/disk/by-uuid/caa1051c-f7c3-4809-9a63-b3908de9c27c";
|
|
fsType = "ext4";
|
|
};
|
|
|
|
swapDevices = [{device = "/dev/disk/by-uuid/53f8fb0f-1fd8-4785-9278-343b525a23be";}];
|
|
|
|
# Enables DHCP on each ethernet and wireless interface. In case of scripted networking
|
|
# (the default) this is the recommended approach. When using systemd-networkd it's
|
|
# still possible to use this option, but it's recommended to use it in conjunction
|
|
# with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
|
|
networking.useDHCP = lib.mkDefault true;
|
|
# networking.interfaces.eno1.useDHCP = lib.mkDefault true;
|
|
# networking.interfaces.eno2.useDHCP = lib.mkDefault true;
|
|
# networking.interfaces.eno3.useDHCP = lib.mkDefault true;
|
|
# networking.interfaces.eno4.useDHCP = lib.mkDefault true;
|
|
|
|
hardware.cpu.intel.updateMicrocode =
|
|
lib.mkDefault config.hardware.enableRedistributableFirmware;
|
|
}
|