xin/pkgs/ble-serial.nix
2024-07-24 08:20:58 -06:00

32 lines
500 B
Nix

{ buildPythonPackage
, setuptools-scm
, fetchFromGitHub
, pyserial
, coloredlogs
, bleak
, ...
}:
buildPythonPackage rec {
pname = "ble-serial";
version = "2.8.0";
nativeBuildInputs = [
setuptools-scm
];
propagatedBuildInputs = [
pyserial
coloredlogs
bleak
];
buildInputs = [ setuptools-scm ];
src = fetchFromGitHub {
owner = "jakeler";
repo = "ble-serial";
rev = "v${version}";
hash = "sha256-KQCnrloBrY7hRt2cFcWiFUg5GgrdbXbcTCNcIuVryZw=";
};
}