27 lines
795 B
Nix
27 lines
795 B
Nix
# Do not modify this file! It was generated by ‘nixos-generate-config’
|
||
# and may be overwritten by future invocations. Please make changes
|
||
# to /etc/nixos/configuration.nix instead.
|
||
{
|
||
config,
|
||
lib,
|
||
modulesPath,
|
||
...
|
||
}: {
|
||
imports = [(modulesPath + "/profiles/qemu-guest.nix")];
|
||
|
||
boot.initrd.availableKernelModules = ["ahci" "xhci_pci" "virtio_pci" "sd_mod"];
|
||
boot.initrd.kernelModules = [];
|
||
boot.kernelModules = ["wireguard"];
|
||
boot.extraModulePackages = [];
|
||
|
||
fileSystems."/" = {
|
||
device = "/dev/disk/by-uuid/b3caa6ff-5610-4ae2-999d-f8f0b1599c4f";
|
||
fsType = "ext4";
|
||
};
|
||
|
||
swapDevices = [{device = "/dev/disk/by-uuid/610a3dbc-59d5-4e5b-b5de-b31402135d44";}];
|
||
|
||
hardware.cpu.intel.updateMicrocode =
|
||
lib.mkDefault config.hardware.enableRedistributableFirmware;
|
||
}
|